composer更新命令及常用命令

Scroll Down

原文地址:https://www.wjcms.net/archives/composer%E6%9B%B4%E6%96%B0%E5%91%BD%E4%BB%A4%E5%8F%8A%E5%B8%B8%E7%94%A8%E5%91%BD%E4%BB%A4

composer作为php的包依赖管理工具,开发者将开发的工具包上传,然后使用者能很方便的使用,今天就总结一下。

composer安装

官方地址:https://getcomposer.org/download/
下载地址:https://getcomposer.org/Composer-Setup.exe
下载后直接安装即可。

检查是否安装完成

使用命令:

composer --version
#注意这里要大写
composer -V


如果如上图一样显示版本号,则说明已经安装成功。
同时,还可以使用新增的

composer -vvv

命令查看更详细的信息,及帮助。

composer升级

如果composer版本升级了该怎么办呢?不要慌,安排。
使用命令:

composer self-update

composer配置镜像

因为composer是国外地址,访问起来特别慢,所以使用的时候很容易出现安装失败的情况,这里的解决办法就是使用镜像,使用composer config命令配置镜像地址即可。这里推荐使用阿里云composer镜像源,优点是快速稳定更新快

全局配置(推荐)

所有项目都会使用该镜像地址:

composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/

取消配置:

composer config -g --unset repos.packagist

当前项目配置

仅修改当前工程配置,仅当前工程可使用该镜像地址:

composer config repo.packagist composer https://mirrors.aliyun.com/composer/

取消配置:

composer config --unset repos.packagist

composer使用

install命令

install 命令可以用于项目初始化后,初次安装依赖,且会优先读取composer.lock中的版本号,以尽可能的保证协作开发中包版本的一致性。

composer install

require命令

require 命令,添加新的依赖包到composer.json文件中并执行更新;

composer require laravel/ui x.0.0 #下载指定版本,可指定 

update命令

update命令无法在命令行中指定包版本号,需要手动修改composer.json文件

composer update

其他常用命令

composer list:获取帮助信息;
composer init:以交互方式填写composer.json文件信息;
composer search:在当前项目中搜索依赖包;
composer show:列举所有可用的资源包;
composer validate:检测composer.json文件是否有效;
composer create-project:基于composer创建一个新的项目;
composer dump-autoload:在添加新的类和目录映射是更新autoloader
composer remove laravel/ui :删除依赖后还需要去vender文件夹里,手动删除