laravel/framework[v8.54.0, ..., 8.x-dev] require league/flysystem ^1.1 ->

laravel/framework[v8.54.0, ..., 8.x-dev] require league/flysystem ^1.1 ->

Scroll Down

Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1
- laravel/framework[v8.54.0, ..., 8.x-dev] require league/flysystem 1.1 -> satisfiable by league/flysystem[1.1.0, ..., 1.x-dev].
- league/flysystem[1.1.0, ..., 1.x-dev] require ext-fileinfo * -> it is missing from your system. Install or enable PHP's fileinfo extension.
- Root composer.json requires laravel/framework
8.54 -> satisfiable by laravel/framework[v8.54.0, ..., 8.x-dev].

To enable extensions, verify that they are enabled in your .ini files:
- /www/server/php/80/etc/php.ini
You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.
截图_选择区域_20211017172506.png

出现上述问题,是因为php缺少fileinfo扩展

解决方法:

linux 可利用宝塔直接安装:
截图_选择区域_20211017172715.png

windows :
找到
;extension=php_fileinfo.dll 这一行

然后去掉前边的分号即可。