侧边栏壁纸
  • 累计撰写 198 篇文章
  • 累计创建 105 个标签
  • 累计收到 36 条评论

pyrsistent requires Python '>=3.5' but the running Python is 2.7.16

神兵小将
2022-04-12 / 0 评论 / 0 点赞 / 51 阅读 / 269 字 / 正在检测是否收录...
温馨提示:
本文最后更新于 2022-04-12,若内容或图片失效,请留言反馈。部分素材来自网络,若不小心影响到您的利益,请联系我们删除。

今天安装docker-compose报错pyrsistent requires Python ‘>=3.5’ but the running Python is 2.7.16
image-1649693944251

错误原因:依赖大于等于3.5版本python,而系统的是2.7.16

解决方法:
使用命令查看当前Python

cd /usr/bin
ls | grep python

即可查到python的命令文件。

image-1649693907372
如上图,发现已经安装了3.7。

于是,只需要运行命令,删除软链,然后重新添加即可。

sudo rm -rf python
sudo ln -s /usr/bin/python3.7 /usr/bin/python
0

评论区