使用vite初始化创建vue3-ts项目

使用vite初始化创建vue3-ts项目

Scroll Down

使用vite初始化创建vue3-ts项目

兼容性注意
Vite 需要 Node.js 版本 >= 12.0.0。

可以使用npm cnpm yarn pnpm等进行安装,当然,这里取决于您自己安装的环境。

1. 使用 NPM:

 npm init vite@latest

2. 使用 Yarn:

 yarn create vite

3.使用 PNPM:

pnpm create vite

然后按照提示操作即可!

这里我们以pnpm为例:

pnpm create vite

20220405_205859.png

输入项目名称

然后按照提示输入项目名称,而后回车即可。
20220405_205940.png

选择框架

然后是选择框架,这里我选择vue 只需要使用方向键上下即可选中,而后回车。
20220405_210411.png

选择vue或vue-ts

vue即为js方式,vue-ts为ts语法,根据自己的需求选择即可。这里我选择ts,建议选择ts,拥有更好体验。
20220405_210346.png

安装依赖包

运行命令

# 进入项目目录
cd ele-admin

# 安装依赖
pnpm i

# 运行项目
pnpm dev

在浏览器中打开,即已完成vite初始化vue-ts项目。
20220405_210817.png